Weird Error on Websphere : java.lang.NoClassDefFoundError: com.ibm.ws.management.configservice.TypeRegistry

I had a very weird error today on WebSphere, very weird because i never had this kind of error before. This error shows up on WebSphere administrative console. This is part of the error’s stacktrace.

An error occurred while processing request:
/ibm/console/secure/layouts/contentLayout.jsp

java.lang.NoClassDefFoundError: com.ibm.ws.management.configservice.TypeRegistry

How to remove is actually very easy, i just delete the tranlog folder on your Websphere folder. This is my complete path of tranlog folder.

C:\Program Files\IBM\WebSphere\AppServer\profiles\AppSrv01\tranlog

Hope it will help others, good luck ;-)

Google+

10 Comments

Vikram Kakkar

about 5 years ago

Deleting the folder worked.. Thanks a lot!!!!

Reply

edwin

about 5 years ago

Hi Vikram, glad it could help :)

JL

about 5 years ago

Hi, thank you man, you save me a lot of time. Could not figure out this error and could not log to the admin console from websphere. thx.

Reply

edwin

about 5 years ago

Hi JL, glad it could helped :)

dev

about 4 years ago

TANKYOU

Reply

edwin

about 4 years ago

You are welcome :)

jenny

about 4 years ago

THANKS A LOT!!! :-D (Y)

Reply

Vivek

about 3 years ago

It Worked! Helped! Thanks Buddy.....

Reply

garryalfa

about 3 years ago

thanks man, its been two years but it still helps me.

Reply

edwin

about 3 years ago

Hi Garry, glad it can help :)

Leave a Comment

Please be polite. We appreciate that.
Your email address will not be published and required fields are marked


:-[ (B) (^) (P) (@) (O) (D) :-S ;-( (C) (&) :-$ (E) (~) (K) (I) (L) (8) :-O (T) (G) (F) :-( (H) :-) (*) :-D (N) (Y) :-P (U) (W) ;-)