Weird Websphere Error : An instance of the server may already be running: servername

I had this weird error today when im trying to start my WAS 7 on Windows Server, somehow my WAS wont startup with some weird error that port 8880 is occupied

ADMU0111E: Program exiting with error: com.ibm.websphere.management.exception.AdminException: ADMU3027E: An instance of the server may already be running: server1

It’s weird because i check using netstat -aon command and see that port 8880 is free.
My workaround is changing file serverindex.xml on WebsphereInstallationFolder\WebSphere\AppServer\profiles\ AppSrv01\config\cells \cellname\nodes\nodename\serverindex.xml and change port 8880 into 8881

 <specialEndpoints xmi:id="NamedEndPoint_1183122129641" endPointName="SOAP_CONNECTOR_ADDRESS">
      <endPoint xmi:id="EndPoint_1183122129641" host="SERVER1" port="8881"/>
 </specialEndpoints>

Hope it helped others,
have fun using Websphere :D

Google+

1 Comment

Digbijoy

about 3 years ago

This is one of the smart way , I changed the soap_connector port as you mentioned on serverindex.xml . One more point I would like to make it here. The server was still not starting up. I am sure many of you faced that issue earlier where it says server starting and not showing server started mode. The solution I found is if you have McAfee running on your system , then you need to disable the host intrusion prevention. How you do this ? Go to McAfee -> Manage Features-> Host Intrusion Prevention Under IPS Policy Tab , click on Task -> unlock user interface Then disable the check box 1) Enable Host IPS and 2) Enable Network IPS Then Apply. Then Task -> Lock User Interface Start the IBM RAD Thanks, Digbijoy.

Reply

Leave a Comment

Please be polite. We appreciate that.
Your email address will not be published and required fields are marked


:-[ (B) (^) (P) (@) (O) (D) :-S ;-( (C) (&) :-$ (E) (~) (K) (I) (L) (8) :-O (T) (G) (F) :-( (H) :-) (*) :-D (N) (Y) :-P (U) (W) ;-)